Get in touch
Back
Maintenance

Authentication System Maintenance

Completed 10 Nov at 06:20pm IST.

Cinema Deck Auth Server
Completed

Maintenance completed

Posted 10 Nov at 06:20pm IST.
Started

Authentication System Server Upgrade

Posted 10 Nov at 05:20pm IST.