Get in touch
Back
Maintenance

Authentication System Maintenance

Completed 23 Oct at 02:06am IST.

Cinema Deck Auth Server
Completed

Maintenance Complete.
All services are now functional

Posted 23 Oct at 02:06am IST.
Started

Authentication may be unavailable for some time.
Affected functionalities :-
Login and Registration

Posted 23 Oct at 12:04am IST.