Get in touch
Back
Maintenance

Authentication System Maintenance

Completed 2 Mar at 07:40pm IST.

Cinema Deck Auth Server
Completed

All systems operational

Posted 2 Mar at 07:40pm IST.
Started

Users may be unable to log in or Register

Posted 2 Mar at 07:07pm IST.