Get in touch
Back
Maintenance

Authentication System Maintenance

Completed 11 Oct at 10:11am IST.

Cinema Deck Auth Server
Completed

Completed maintenance of Auth server

Posted 11 Oct at 10:11am IST.
Started

Maintenance of Auth server.

Posted 11 Oct at 10:00am IST.